InstallSynthAModeler

From CCRMA Wiki

(Difference between revisions)
Jump to: navigation, search
Line 19: Line 19:
make
make
sudo make install
sudo make install
 +
Line 26: Line 27:
[[Media:Example.ogg]]
[[Media:Example.ogg]]
-
sudo apt-get install jackd1 qjackctl
+
sudo apt-get update
 +
sudo apt-get install libjack-dev jackd1 qjackctl
-
sudo apt-get update
 
-
sudo apt-get install libqt4-core qt4-qmake libqt4-dev
+
 
 +
sudo apt-get install libqt4-dev libqt4-core qt4-qmake  
For Ubuntu precise
For Ubuntu precise
Line 41: Line 43:
Download the [http://sourceforge.net/projects/faudiostream/files/faust-0.9.58.zip/download Faust source for version 0.9.58]
Download the [http://sourceforge.net/projects/faudiostream/files/faust-0.9.58.zip/download Faust source for version 0.9.58]
 +
== Troubleshooting ==
== Troubleshooting ==
Requires minimum Perl version 5.10
Requires minimum Perl version 5.10
 +
 +
The following kinds of errors can for instance happen if you ever upgraded Faust but forgot to remove the older version of Faust:
 +
error: macro "max" passed 3 arguments, but takes just 2
 +
or other particularly errors involving some standard template libraries, then please make sure you only have one version of Faust installed. You can remove all older versions of Faust by entering into each of their source directories and running
 +
sudo make uninstall
 +
(Then of course you will need to reinstall you favorite version of Faust 0.9.58 by going into its source directory and running ''sudo make install'')

Revision as of 04:09, 5 April 2013

Mac OS X

Requirements: Intel CPU

  • First install XCode Developer tools

https://developer.apple.com/xcode/

and make sure that command line tools are installed. (Alternative to XCode: https://github.com/kennethreitz/osx-gcc-installer)


When installing Jack, maybe you want to have the 64/32 bit version.

Download and install the Jack Audio Server for OS X (after you install this you will need to restart).

http://qt-project.org/downloads Then get "Qt libraries 4.8.4 for Mac (185 MB)" and install it (takes about 5 minutes excluding download time)


Then inside the Faust directory: make sudo make install


Linux

For beginners, Media:Example.ogg

sudo apt-get update

sudo apt-get install libjack-dev jackd1 qjackctl


sudo apt-get install libqt4-dev libqt4-core qt4-qmake

For Ubuntu precise



For advanced users,

Download the Faust source for version 0.9.58


Troubleshooting

Requires minimum Perl version 5.10

The following kinds of errors can for instance happen if you ever upgraded Faust but forgot to remove the older version of Faust: error: macro "max" passed 3 arguments, but takes just 2 or other particularly errors involving some standard template libraries, then please make sure you only have one version of Faust installed. You can remove all older versions of Faust by entering into each of their source directories and running sudo make uninstall (Then of course you will need to reinstall you favorite version of Faust 0.9.58 by going into its source directory and running sudo make install)

Personal tools